Fail to submit for credentials requets "Fail to Fetch"

I attempted to register for credentials as an individual through the form at Ego4D Dataset. However, when I tried to submit the page, it displayed an error message stating ‘fail to fetch’. I have attempted this on multiple browsers without success.

I meet the same issue :frowning:

Maybe related issue. For both individual and organization I’m failing to submit my request at Ego4D Dataset. It just shows “Load failed”.

The problem still stands. Ive also attempted through different computers, different browsers and different VPNs. What other options do we have to ask for a license?

Hello! We are sorry to hear about this. We are looking into the issue now.

Hey @gperezsantamaria, I’ve just tested signup with a fresh email and it seems to be working. Can you please try again, else share a screenshot of your form before submission to so we can replicate?

1 Like

Thank for the quick response @dkukreja , i was about to try again to show the problem and now it simply worked and got the same confirmation message you showed.

Im happy but confused, if it is worth anything, in the developer console, yesterday the problem code was related to a CORS when trying the underlying POST request.