Unable to download 'captures' part of the dataset

I tried downloading recommended dataset. After downloading much of the data, it failed without much descriptive error. I tried downloading every part one by one. It looks like ‘captures’ subpart has some issues. Below are error logs from my terminal. Can you help solve it? Thanks.

>>> egoexo -o <dir> --parts captures -y
Obtaining part metadata ...
100%|██████████████████████████████████████████████████████████████████████| 1/1 [00:05<00:00,  5.40s/it]
Checking current download status ...
100%|███████████████████████████████████████████████████████████████| 8061/8061 [00:15<00:00, 529.70it/s]
Downloaded: 100.000% = 40.622GiB / 40.622GiB (8046 / 8061 files) downloaded
Preparing output directories ...
100%|██████████████████████████████████████████████████████████████| 1574/1574 [00:00<00:00, 3137.88it/s]
Downloading ...
Fetching: 0.000GiB
  0%|                                                                       | 0.00/25.6k [00:00<?, ?iB/s]
WARN: failed to fetch 15 files [integrity=0, exceptions=15]
Please retry the download (... returning with error code 2)
  0%|                                                                       | 0.00/25.6k [00:15<?, ?iB/s]

Hi, this is now resolved. Sorry for the inconvenience.

Hello @miguelmartin , thanks for your reply. I am still not able to download it. It is giving me the same error with the same command.

I am also having the same problem. I cannot download the “captures” part and here is my error log: