(egoexo) error downloading ego_pose

Hi EgoExo4D team,

I tried to download the ego_pose_pseudo_gt data, but I got AssertionError. Could I ask how to resolve this?

  • Info about ego_pose_pseudo_gt
  • Run command:

~/Ego4d$ egoexo -o ${OUTDIR} --parts takes captures ego_pose_pseudo_gt trajectory eye_gaze

  • Error:

File “/data2/user/miniconda3/envs/ego4d/lib/python3.11/site-packages/ego4d/egoexo/download/cli.py”, line 11, in main


File “/data2/user/miniconda3/envs/ego4d/lib/python3.11/site-packages/ego4d/internal/download/cli.py”, line 185, in main

assert pathmgr.exists(

AssertionError: ego_pose_pseudo_gt does not have a manifest path (looking at s3://ego4d-consortium-sharing/egoexo-public/v1/ego_pose_pseudo_gt/manifest.json)


Wanhee Lee

Hi @wlee

We are sorry for the confusion here. EgoPose is currently being updated and we are expecting it to be available Monday EOD/Tuesday morning.

When it is available you will be able to download the annotations via --parts annotations and can filter it via --benchmarks egopose. ego_pose_pseudo_gt is automatically generated ground truth data and is on the same timeline as above.

Apologies for the inconvenience.

I have recently discovered a downloader issue. If you have files in your <download_dir>/captures/captures or <download_dir/takes/takes, please use the following script to correct it: fix_ego4d_download_data.py · GitHub and re-download with the downloader with the -d option

Getting the same error while downloading annotations for key-step annotations as well.

egoexo -o <out_dir> --parts annotations --benchmarks keystep --splits train


AssertionError: annotations does not have a manifest path (looking at s3://ego4d-consortium-sharing/egoexo-public/v1/annotations/manifest.json)

Strange. I’ll have a look at this issue first thing tomorrow morning.

Could you explain why I should re-download the file?

I am not suggesting to re-download the files. The script will move files to their correct location, due to a bug on the downloader. Files should not be located in <download-dir>/captures/captures/ or <download-dir>/takes/takes - if there is files, use my script https://gist.github.com/miguelmartin75/b2bfeec06e51ce217ab2613761d9cd7b

After you’ve used my script, -d in the downloader will (1) check if there is anything missing and (2) delete any unnecessary files.

1 Like

This command works for me. Can you please re-try? If it still does not work please let me know, thanks @tarunk23

This may be an issue with you configuring your aws client. To do so, you need to ensure the aws CLI is installed, please run

aws configure

and insert your keys after doing so

1 Like

Sorry, you are right. My bad, I did not configure aws. It works now! Thanks!


Is the egocentric pose annotations available now?